Russian Fedora

cообщество русскоязычных участников
международного проекта Fedora

Поддержка SysV-скриптов уровня early-boot удаляется из systemd

Это архивная статья

Lennart Poettering анонсировал удаление поддержки SysV-скриптов самой ранней стадии загрузки из SysV-to-systemd генератора.

Это не затронет уровень совместимости с "обычными" SysV-скриптами - лишь ту их часть, что работает на этапе загрузки системы (уровень 'S', 'b' и т.п.). Эти уровни никогда не были толком стандартизованы и их реализация отличается от дистрибутива к дистрибутиву. Самое время выкинуть их вообще в пользу стандартного решения - service-файлов systemd.

Среди дистрибутивов, которые затронуты этим изменением - Debian/Ubuntu, SUSE, Angstrom. Их мэйнтейнерам рекомендуется срочно принять меры по обеспечению совместимости с systemd. Конечно, перейдя на systemd на таком уровне, больше не будет шансов вернуться назад и поддерживать одновременно SysV-скрипты (как это, например, делает SUSE сейчас, пытаясь ублажить ретроградов, требующих привычную им систему загрузки).

Комментарии